ホームページ

WordPressのテーマをアップデートしたらエラーが出た話【解決済み】

2022年5月14日

WordPressのテーマをアップデートしたらエラーが出た話【解決済み】

最近、使っているテーマをアップロードしたらエラーが出て真っ白になりました(笑)
どうも、DAISUKEです!(@desing_d

これでもそこそこWordPressのテーマを日本や海外製も含めて触ってきたつもりでしたが、久しぶりにWordPressのテーマをアップデートしたら真っ白になる現象に遭遇しました。

このサイトで重大なエラーが発生しました。
WordPressのトラブルシューティングについてはこちらをご覧ください

こんな感じで出てきて、ダッシュボードには入れるけどサイトは上記のエラー文章だけでないも表示されないという感じですね。

結論を言ってしまうと、今回の私のエラーの原因はPHPのバージョンでした。
エックスサーバーでPHPのバージョンを下げてあげたら治りました。

一応そこに行き着いた理由なども簡単に説明していきますね。

スポンサーリンク

WordPressのテーマをアップデートしたらエラーが出た話【解決済み】

本来は、テーマのアップデートをする場合はバックアップなどを取るのが安パイではありますが、実際問題面倒というのも事実であり、私は面倒だったのでそのままアップデートしてしまいました。

そしたらエラーが出たので、慌てて旧のテーマファイルを引っ張ってきて適応したら戻ったという感じですね。
とりあえず、確認した物は

  • プラグインをOFF
  • ローカル環境で動くか確認
  • PHPのバージョンを切り替える

こんな感じです。
簡単に書いていきますね。

プラグインをOFF

基本的にWordPressで何かしろのエラーが出る!となると、プラグインが悪さしているのではないか?と思いますよね。
なので、とりあえず凡ゆるプラグインを一度OFFにしてみましたが今回は全く関係がありませんでした。

テーマのアップデートでのエラーなので新しい機能が増えない限りはよっぽど大丈夫だとは思うのですが、一応一番簡単で良くあるパターンでプラグインを見てみるを最初にしました。

ローカル環境で動くか確認

次に、他のサーバーでも動くのか?と思ったのでローカル環境にデータを持ってきてテーマをアップデートしたら表示されました。
つまり、サーバーサイドの設定や機能に問題があるのでは?となった訳です。

私は、エックスサーバーを使っているので、高速化するために色々なサービス?的な物を設定しているのでそれらが原因かな?と思いオフにしましたが変化なし!
さてどうした物かで考えたらPHPのバージョンを思い出しました。

PHPのバージョンを切り替える

普段あまり触らないのですが、PHPのバージョンが何故か8.0.12になっていたので、推奨の7.4.25に変更したら普通に表示されました。
完全にPHPバージョンの問題でしたね。

そもそも、いつ8にしたのかも全く分からないのが少し怖いですね。

スポンサーリンク

WordPressのテーマをアップデートしたらエラーが出た話【まとめ】

このようなエラーは突然出てくるので結構焦りますよね。
やはり、アップデートを行う時などはバックアップは大事ですね。
一応サーバー側でのバックアップはしていますが、それも不安なのでこらからはテーマのアップデートの時もバックアップを取ることにします(笑)

それでは、読んでいただいてありがとうございました!
DAISUKEでした。(@desing_d

YouTubeでラジオ配信などもしているので、興味がある方は是非とも聞いてみてください。
思考のバランスを発信しているラジオです
↓※チャンネル登録してくれると嬉しいです♪
>>YouTube:思考のバランスラジオ | DAISUKE Voice Blog

■notoで日記も書いています
>>noto:DAISUKE@思考のバランス

スポンサーリンク

最近のマイブーム

  • この記事を書いた人

DAISUKE

本サイト『Dデザイング』を運営しています。"だいすけ"です。
何となく生きづらい世の中なので
少しでも楽しく生きれる人が増えると良いなと思っています。
思考のバランスを発信していきます。
仕事:会社員です。HPを作ったり、デザインやパソコンの管理などもしています。
趣味:パソコン/植物/生き物/読書/アニメ/ラノベ/漫画など…
ブログ:約1300記事以上、ラジオ400本以上更新中

-ホームページ
-, , ,